Calculer un CUMP à chaque entrée avec Excel

Vous trouverez sur cette page un exemple de création d’une feuille Excel permettant de suivre simplement un stock valorisé en CUMP à chaque entrée.

Ce pas à pas utilise la version Excel 2016.

Formules Excel utilisées

Voici les fonctions utilisées pour créer ce tableur :
SI Support Microsoft
– ESTERR – Support Microsoft

Création de la feuille de calcul

La feuille de calcul comprend les colonnes suivantes : Date, Type de mouvement, Entrées (quantité, prix unitaire, valeur), Sorties (quantité, prix unitaire, valeur), Stock restant (quantité, CUMP, valeur).
Le CUMP sera calculé à chaque entrée dans la colonne CUMP.
CUMP_chaque_entree_excel_1

Mise en place des formules

La valeur des entrées est valorisée en multipliant la quantité (C3) par le prix unitaire (D3), uniquement si une quantité est entrée : =SI(C3=“”;“”;D3*C3)
CUMP_chaque_entree_excel_2

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_3

La première ligne des sorties n’est pas paramétrée car le premier mouvement est obligatoirement une entrée (il est difficile de sortir un stock qui n’est pas encore entré). Si une quantité est sortie (F4 non vide), le prix unitaire de cette sortie est pris en compte en récupérant le CUMP du mouvement précédent (J3) : =SI(F4=«»;«»;J3)
Sinon le prix unitaire reste vide.
CUMP_chaque_entree_excel_4

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_5

Si un prix unitaire est présent (G4 non vide), la valeur du mouvement est calculée (G4*F4) : =SI(G4=«»;«»; G4*F4)
Sinon la cellule reste vide.
CUMP_chaque_entree_excel_6

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_7

La première quantité du stock restant reprend la première quantité entrée.
CUMP_chaque_entree_excel_8

La quantité suivante du stock restant en additionnant la quantité précédente à la quantité entrée et en soustrayant la quantité sortie, uniquement si une quantité est entrée ou sortie.
=SI(C4+F4=0;«»;I3+C4+F4)
CUMP_chaque_entree_excel_9

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_10

Le premier CUMP est obtenu en divisant la valeur de la première entrée par sa quantité.
CUMP_chaque_entree_excel_11

Le second CUMP est calculé uniquement si une entrée est effectuée, sinon le prix de la sortie est repris (le prix de la sortie reprend le CUMP de la ligne précédente).
=SI(C4=“”;G4;(K3+E4)/I4)
CUMP_chaque_entree_excel_12

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_13

La valeur du stock restant est calculée en divisant la quantité restante par le CUMP. La cellule n’affiche rien si aucun CUMP n’a encore été calculé, ce qui donnerait l’affichage d’une erreur.
=SI(ESTERR(J3*I3);«»;J3*I3)
CUMP_chaque_entree_excel_14

La formule est tirée dans toute la colonne.
CUMP_chaque_entree_excel_15

Saisie des données dans le tableau

La première entrée est saisie. Les valeurs du stock restant s’affichent.
CUMP_chaque_entree_excel_16

Deux autres entrées sont saisies. Le stock restant se met à jour avec un CUMP recalculé à chaque entrée.
CUMP_chaque_entree_excel_17

Une sortie est saisie (seule la quantité de la sortie est saisie), le CUMP de l’entrée précédente est utilisé pour la valoriser.
CUMP_chaque_entree_excel_18

D’autres mouvements sont saisis. Le CUMP est mis à jour à chaque nouvelle entrée et ce CUMP actualisé est utilisé pour les sorties suivantes. CUMP_chaque_entree_excel_19

En savoir plus

Billets similaires



Les derniers liens de notre annuaire :

- XL : Comment calculer les intérêts composés
- Excel: Vous pensez tout connaître de la fonction INDEX?
- Comment réaliser un graphique sur Excel ?
- Exemple et modèle de tableau de bord Excel en ligne
- Graphiques Excel et Indicateurs de Performance KPI
- Présentez vos écarts au budget de façon percutante | Le CFO masqué
- Excel pour gérer simplement vos stocks | Espace Pédagogique Laurent BOUCARD
- Les Sparklines pour le Tableau de Bord
- Excel: Attention aux axes secondaires de vos graphiques
- Comment utiliser le Diagramme Courbe et le Diagramme Aire

2 comments

Laisser un commentaire